NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

Prototype Pollution in set-inGHSA-6956-83fg-5wc5

CRITICALFix: ahdinosaur/set-in@6bad255

GHSA-6956-83fg-5wc5 is a critical-severity (CVSS 9.8) CWE-1321 vulnerability in set-in. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for set-in — see the affected versions and patch details below.

Also known asCVE-2022-25354SNYK-JS-SETIN-2388571
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
0.23%0.96%1.70%2.43%0.7%1.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

3other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
set-innpm
271downloads / week

Description

The package set-in before 2.0.3 is vulnerable to Prototype Pollution via the setIn method, as it allows an attacker to merge object prototypes into it. Note: This vulnerability derives from an incomplete fix of CVE-2020-28273

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmset-inall versions2.0.3npm install set-in@2.0.3

Affected Products

1 product · 1 configurations
Application
set-inset-in_project
< 2.0.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for set-in, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update set-in to 2.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6956-83fg-5wc5 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The package set-in before 2.0.3 is vulnerable to Prototype Pollution via the `setIn` method, as it allows an attacker to merge object prototypes into it. **Note:** This vulnerability derives from an incomplete fix of [CVE-2020-28273](https://security.snyk.io/vuln/SNYK-JS-SETIN-1048049)
O3 Security · Impact-Aware SCA

Is GHSA-6956-83fg-5wc5 in your dependencies?

Find it across npm, including transitive dependencies.

GHSA-6956-83fg-5wc5: set-in — Fixed in 2.0.3