@angular/core: Angular Template and Dynamic Component Namespace Bypass leading to Cross-Site Scripting (XSS)GHSA-692r-grfm-v8x7
MEDIUMFix: angular/angular#68686GHSA-692r-grfm-v8x7 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in @angular/core. A fix is available for @angular/core — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-692r-grfm-v8x7.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@angular/corenpmDescription
An issue in the @angular/core package allows bypassing script-execution restrictions during dynamic component creation.
Specifically, the dynamic component instantiation mechanism (createComponent) failed to reject mounting components directly onto a <script> or namespaced script element (such as <svg:script>). This enabled the initialization of custom components on a tag that executes scripts, allowing attackers to hijack or inject script-executing hosts.
This flaw enables an attacker who can control the host element or selector parameter passed to createComponent to initialize or mount an Angular component directly onto a <script> tag, leading to execution of untrusted code or client-side Cross-Site Scripting (XSS).
Impact
Any Angular application that registers dynamic components based on user-supplied parameters (like selectors or host elements) is vulnerable to this security bypass.
Once exploited, this allows a malicious actor to mount a dynamic component on a script tag, bypassing core dynamic component creation safeguards to execute arbitrary JavaScript within the target user's browser context. This could lead to session hijacking, sensitive data exposure, or unauthorized actions on behalf of the user.
Attack Preconditions
To successfully exploit these vulnerabilities, the following environment parameters and application states must all concurrently exist:
- User-Controlled Host Selection: The application must accept user-controlled inputs that are passed as a selector/host element to
createComponent. - Absence of Additional Context Sanitization: The application does not perform separate input sanitization before feeding values to the dynamic creation APIs.
Patches
- 22.0.0-rc.2
- 21.2.15
- 20.3.22
- 19.2.23
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @angular/core | ≥ 21.0.0-next.0&&< 21.2.15 | 21.2.15npm install @angular/core@21.2.15 |
| 📦npm | @angular/core | ≥ 22.0.0-next.0&&< 22.0.0-rc.2 | 22.0.0-rc.2npm install @angular/core@22.0.0-rc.2 |
| 📦npm | @angular/core | ≥ 19.0.0-next.0&&< 19.2.23 | 19.2.23npm install @angular/core@19.2.23 |
| 📦npm | @angular/core | all versions | No fix |
| 📦npm | @angular/core | ≥ 20.0.0-next.0&&< 20.3.22 | 20.3.22npm install @angular/core@20.3.22 |
Affected Products
angularangularDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @angular/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @angular/core to 21.2.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-692r-grfm-v8x7 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat has evaluated this vulnerability and determined that most products listed as shipping @angular/core in their SBOMs are not affected. The majority of flagged components (firefox, thunderbird, mozjs, gjs, intel-cmt-cat, syncthing, ceph, and others) either do not use the Angular framework at all (technology…
Users of applications built with @angular/core versions prior to 19.2.23, 20.3.22, 21.2.15, or 22.0.0-rc.2 should upgrade to the fixed versions. Applications that do not use the createComponent API with user-controlled host element parameters are not exploitable.Source: Red Hat security advisory for GHSA-692r-grfm-v8x7 (CC BY 4.0)
Frequently Asked Questions
Is GHSA-692r-grfm-v8x7 in your dependencies?
Find it across npm, including transitive dependencies.