Arbitrary Code Execution in TYPO3 CMSGHSA-67wg-6j7r-mqh8
CRITICALGHSA-67wg-6j7r-mqh8 is a critical-severity (CVSS 9.9) vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.
Real-World Exposure
typo3/cms🐘typo3/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Due to a missing file extension in the fileDenyPattern, backend user are allowed to upload *.pht files which can be executed in certain web server setups. The new default fileDenyPattern is the following, which might have been overridden in the TYPO3 Install Tool.
\.(php[3-7]?|phpsh|phtml|pht)(\..*)?$|^\.htaccess$
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms | ≥ 7.6.0&&< 7.6.22 | 7.6.22composer require typo3/cms:^7.6.22 |
| 🐘Packagist | typo3/cms | ≥ 8.0.0&&< 8.7.5 | 8.7.5composer require typo3/cms:^8.7.5 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms to 7.6.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-67wg-6j7r-mqh8 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-67wg-6j7r-mqh8 in your dependencies?
Find it across Packagist, including transitive dependencies.