NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Cross-Site Scripting in TYPO3 BackendGHSA-5wx6-xwxf-q8qj

MEDIUM

GHSA-5wx6-xwxf-q8qj is a medium-severity (CVSS 4.6) vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.

Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Dec 2, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

3 pkgs affected
🐘typo3/cms🐘typo3/cms🐘typo3/cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Failing to properly encode user input, some backend components are vulnerable to Cross-Site Scripting. A valid backend user account is needed to exploit this vulnerability.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms≥ 6.2.0&&< 6.2.206.2.20composer require typo3/cms:^6.2.20
🐘Packagisttypo3/cms≥ 7.6.0&&< 7.6.57.6.5composer require typo3/cms:^7.6.5
🐘Packagisttypo3/cms≥ 8.0.0&&< 8.0.18.0.1composer require typo3/cms:^8.0.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms to 6.2.20 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5wx6-xwxf-q8qj is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Failing to properly encode user input, some backend components are vulnerable to Cross-Site Scripting. A valid backend user account is needed to exploit this vulnerability.
O3 Security · Impact-Aware SCA

Is GHSA-5wx6-xwxf-q8qj in your dependencies?

Find it across Packagist, including transitive dependencies.

Cross-Site Scripting in TYPO3 Backend (Medium 4.6)