NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

Jenkins Cadence vManager Plugin disables SSL/TLS and hostname verificationGHSA-5j9f-5wmp-7f8h

HIGHFix: jenkinsci/vmanager-plugin@639aa13

GHSA-5j9f-5wmp-7f8h is a high-severity (CVSS 8.2) CWE-295 vulnerability in org.jenkins-ci.plugins:vmanager-plugin. A fix is available for org.jenkins-ci.plugins:vmanager-plugin — see the affected versions and patch details below.

Also known asCVE-2019-10446
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs63th percentile — riskier than 63% of all scored CVEsHighest risk
0.00%0.50%1.00%1.49%0.1%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:vmanager-plugin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Jenkins Cadence vManager Plugin prior to version 2.7.1 disables SSL/TLS and hostname verification globally for the Jenkins master JVM. This issue is patched in 2.7.1

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:vmanager-pluginall versions2.7.1org.jenkins-ci.plugins:vmanager-plugin:2.7.1

Affected Products

1 product · 1 configurations
Application
cadence vmanagerjenkins
≤ 2.7.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:vmanager-plugin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:vmanager-plugin to 2.7.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5j9f-5wmp-7f8h is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Jenkins Cadence vManager Plugin prior to version 2.7.1 disables SSL/TLS and hostname verification globally for the Jenkins master JVM. This issue is patched in 2.7.1
O3 Security · Impact-Aware SCA

Is GHSA-5j9f-5wmp-7f8h in your dependencies?

Find it across Maven, including transitive dependencies.

Jenkins Cadence vManager Plugin disables SSL/TLS and…