NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Cross-Site Scripting in gitbookGHSA-5h5r-23r4-m87h

MEDIUM

GHSA-5h5r-23r4-m87h is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in gitbook. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for gitbook — see the affected versions and patch details below.

Also known asCVE-2017-16019
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk-0.01%
Lower risk than most CVEs60th percentile — riskier than 60% of all scored CVEsHighest risk
0.00%0.48%0.96%1.44%0.2%0.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, a proxy for how much of the ecosystem is exposed.

gitbooknpm
6Kdownloads / week

Description

GitBook is a command line tool (and Node.js library) for building beautiful books using GitHub/Git and Markdown (or AsciiDoc). Stored Cross-Site-Scripting (XSS) is possible in GitBook before 3.2.2 by including code outside of backticks in any ebook. This code will be executed on the online reader.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmgitbookall versions3.2.2npm install gitbook@3.2.2

Affected Products

1 product · 1 configurations
Application
gitbookgitbook
< 3.2.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for gitbook, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update gitbook to 3.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5h5r-23r4-m87h is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Affected versions of `gitbook` do not properly sanitize user input outside of backticks, which may result in cross-site scripting in the online reader. ## Recommendation Update to version 3.2.2 or later.
O3 Security · Impact-Aware SCA

Is GHSA-5h5r-23r4-m87h in your dependencies?

Find it across npm, including transitive dependencies.

Cross-Site Scripting in gitbook (Medium 6.1)