NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

Unrestricted File Upload vulnerability in Firefly IIIGHSA-5gq7-826w-8282

HIGHFix: firefly-iii/firefly-iii@a85b642

GHSA-5gq7-826w-8282 is a high-severity (CVSS 8.8) Unrestricted File Upload vulnerability in grumpydictator/firefly-iii. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for grumpydictator/firefly-iii — see the affected versions and patch details below.

Also known asCVE-2021-3846
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs56th percentile — riskier than 56% of all scored CVEsHighest risk
0.00%0.43%0.85%1.28%0.2%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘grumpydictator/firefly-iii

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

firefly-iii is vulnerable to Unrestricted Upload of File with Dangerous Type

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistgrumpydictator/firefly-iiiall versions5.6.2composer require grumpydictator/firefly-iii:^5.6.2

Affected Products

1 product · 1 configurations
Application
firefly iiifirefly-iii
< 5.6.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for grumpydictator/firefly-iii, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update grumpydictator/firefly-iii to 5.6.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5gq7-826w-8282 is resolved across your whole dependency graph.

  3. Workarounds

    Treat uploaded files as untrusted until proven otherwise: validate the actual content type rather than the supplied extension, store uploads outside the web root on a volume mounted without execute permission, and rename them to server-generated identifiers so an attacker cannot choose the path a request will later resolve.

Frequently Asked Questions

firefly-iii is vulnerable to Unrestricted Upload of File with Dangerous Type
O3 Security · Impact-Aware SCA

Is GHSA-5gq7-826w-8282 in your dependencies?

Find it across Packagist, including transitive dependencies.

Unrestricted File Upload vulnerability in Firefly III (High 8.8)