Apache Ranger Vulnerable to Improper Validation of Certificate with Host MismatchGHSA-5fvg-qwcp-r325
MEDIUMGHSA-5fvg-qwcp-r325 is a medium-severity (CVSS 5.3) CWE-297 vulnerability in org.apache.ranger:ranger-nifi-registry-plugin. A fix is available for org.apache.ranger:ranger-nifi-registry-plugin — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-5fvg-qwcp-r325.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.ranger:ranger-nifi-registry-pluginReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Hostname verification bypass issue in Apache Ranger NiFiRegistryClient/NiFiClient is reported in Apache Ranger versions <= 2.7.0.
Users are recommended to upgrade to version 2.8.0, which fixes this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.ranger:ranger-nifi-registry-plugin | all versions | 2.8.0org.apache.ranger:ranger-nifi-registry-plugin:2.8.0 |
Affected Products
rangerapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.ranger:ranger-nifi-registry-plugin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.ranger:ranger-nifi-registry-plugin to 2.8.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5fvg-qwcp-r325 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-5fvg-qwcp-r325 in your dependencies?
Find it across Maven, including transitive dependencies.