NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

Inefficient Regular Expression Complexity in koaGHSA-593f-38f6-jp5m

Fix: koajs/koa@5054af6

GHSA-593f-38f6-jp5m is a CWE-1333 vulnerability in koa. A fix is available for koa — see the affected versions and patch details below.

Also known asCVE-2025-25200
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-593f-38f6-jp5m.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.89%1.34%0.5%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

4 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

8Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
koanpm
9.8Mdownloads / week

Description

Koa is expressive middleware for Node.js using ES2017 async functions. Prior to versions 0.21.2, 1.7.1, 2.15.4, and 3.0.0-alpha.3, Koa uses an evil regex to parse the X-Forwarded-Proto and X-Forwarded-Host HTTP headers. This can be exploited to carry out a Denial-of-Service attack. Versions 0.21.2, 1.7.1, 2.15.4, and 3.0.0-alpha.3 fix the issue.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
📦npmkoa≥ 2.0.0&&< 2.15.42.15.4npm install koa@2.15.4
📦npmkoa≥ 3.0.0-alpha.0&&< 3.0.0-alpha.33.0.0-alpha.3npm install koa@3.0.0-alpha.3
📦npmkoa≥ 1.0.0&&< 1.7.11.7.1npm install koa@1.7.1
📦npmkoaall versions0.21.2npm install koa@0.21.2

Affected Products

1 product · 6 configurations
Application
koakoajs
≥ 2.0.0 && < 2.15.4
1 version
3.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for koa, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update koa to 2.15.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-593f-38f6-jp5m is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Summary Koa uses an evil regex to parse the `X-Forwarded-Proto` and `X-Forwarded-Host` HTTP headers. This can be exploited to carry out a Denial-of-Service attack. ### PoC Coming soon. ### Impact This is a Regex Denial-of-Service attack and causes memory exhaustion. The regex should be improved and empty values should not be allowed.
O3 Security · Impact-Aware SCA

Is GHSA-593f-38f6-jp5m in your dependencies?

Find it across npm, including transitive dependencies.

Inefficient Regular Expression Complexity in koa