CVE-2025-25200 — koa
Fix: koajs/koa@5054af6CVE-2025-25200 is a CWE-1333 vulnerability in koa. A fix is available for koa — see the affected versions and patch details below.
Koa has Inefficient Regular Expression Complexity
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-25200.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
koanpmDescription
Koa is expressive middleware for Node.js using ES2017 async functions. Prior to versions 0.21.2, 1.7.1, 2.15.4, and 3.0.0-alpha.3, Koa uses an evil regex to parse the X-Forwarded-Proto and X-Forwarded-Host HTTP headers. This can be exploited to carry out a Denial-of-Service attack. Versions 0.21.2, 1.7.1, 2.15.4, and 3.0.0-alpha.3 fix the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | koa | ≥ 2.0.0&&< 2.15.4 | 2.15.4npm install koa@2.15.4 |
| 📦npm | koa | ≥ 3.0.0-alpha.0&&< 3.0.0-alpha.3 | 3.0.0-alpha.3npm install koa@3.0.0-alpha.3 |
| 📦npm | koa | ≥ 1.0.0&&< 1.7.1 | 1.7.1npm install koa@1.7.1 |
| 📦npm | koa | all versions | 0.21.2npm install koa@0.21.2 |
Affected Products
koakoajsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for koa, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update koa to 2.15.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-25200 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-25200 in your dependencies?
Find it across npm, including transitive dependencies.