request-baskets vulnerable to Server-Side Request ForgeryGHSA-58g2-vgpg-335q
MEDIUMGHSA-58g2-vgpg-335q is a medium-severity (CVSS 6.5) Server-Side Request Forgery (SSRF) vulnerability in github.com/darklynx/request-baskets. 8 public exploit or proof-of-concept references are indexed, so weaponization risk is real. The records list no fixed version yet; check the vendor advisory below and apply the mitigations in the meantime.
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for GHSA-58g2-vgpg-335q.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/darklynx/request-basketsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
request-baskets up to v1.2.1 was discovered to contain a Server-Side Request Forgery (SSRF) via the component /api/baskets/{name}. This vulnerability allows attackers to access network resources and sensitive information via a crafted API request.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/darklynx/request-baskets | all versions | No fix |
Affected Products
request basketsrbasketsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/darklynx/request-baskets, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Remediation status
The records we use list no patched version of github.com/darklynx/request-baskets for GHSA-58g2-vgpg-335q. Check the maintainer's advisory, and where your build allows, override or pin the dependency away from the vulnerable range.
Mitigate without a patch
Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.
How to detect GHSA-58g2-vgpg-335q
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id ghsa-58g2-vgpg-335q -u https://target- Template
- Request-Baskets <= 1.2.1 - Server Side Request Forgery
- Severity
- medium
- Impact
- Attackers can perform SSRF attacks to access internal network resources, scan internal systems, or interact with services that should not be accessible from external networks.
- Remediation
- Upgrade to Request-Baskets version 1.2.2 or later that addresses this SSRF vulnerability.
Template by ProjectDiscovery nuclei-templates (Jaenact), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is GHSA-58g2-vgpg-335q in your dependencies?
Find it across Go, including transitive dependencies.