Claude SDK for TypeScript: Memory Tool Path Validation Allows Sandbox Escape to Sibling DirectoriesGHSA-5474-4w2j-mq4c
MEDIUMFix: anthropics/anthropic-sdk-typescript@0ac69b3GHSA-5474-4w2j-mq4c is a medium-severity (CVSS 5.4) Path Traversal vulnerability in @anthropic-ai/sdk. A fix is available for @anthropic-ai/sdk — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-5474-4w2j-mq4c.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@anthropic-ai/sdknpmDescription
Claude SDK for TypeScript provides access to the Claude API from server-side TypeScript or JavaScript applications. From version 0.79.0 to before version 0.81.0, the local filesystem memory tool in the Anthropic TypeScript SDK validated model-supplied paths using a string prefix check that did not append a trailing path separator. A model steered by prompt injection could supply a crafted path that resolved to a sibling directory sharing the memory root's name as a prefix, allowing reads and writes outside the sandboxed memory directory. This issue has been patched in version 0.81.0.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @anthropic-ai/sdk | ≥ 0.79.0&&< 0.81.0 | 0.81.0npm install @anthropic-ai/sdk@0.81.0 |
Affected Products
claude sdk for typescriptanthropicDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @anthropic-ai/sdk, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @anthropic-ai/sdk to 0.81.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5474-4w2j-mq4c is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is GHSA-5474-4w2j-mq4c in your dependencies?
Find it across npm, including transitive dependencies.