NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

Zope Object Database (ZODB) vulnerable to arbitrary Python code execution in ZEO storage serversGHSA-4x83-5gw5-q346

CRITICAL

GHSA-4x83-5gw5-q346 is a critical-severity (CVSS 9.8) Code Injection vulnerability in zodb3. A fix is available for zodb3 — see the affected versions and patch details below.

Also known asCVE-2009-0668PYSEC-2009-8
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
0.14%0.98%1.82%2.66%0.6%2.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍zodb3

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Unspecified vulnerability in Zope Object Database (ZODB) before 3.8.2, when certain Zope Enterprise Objects (ZEO) database sharing is enabled, allows remote attackers to execute arbitrary Python code via vectors involving the ZEO network protocol.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIzodb3all versions3.8.2pip install --upgrade 'zodb3==3.8.2'

Affected Products

1 product · 17 configurations
Application
zodbzope
≤ 3.8.1
16 versions
2.8.112.9.112.10.92.11.43.13.1.13.23.2.43.33.3.33.43.4.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zodb3, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update zodb3 to 3.8.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4x83-5gw5-q346 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Unspecified vulnerability in Zope Object Database (ZODB) before 3.8.2, when certain Zope Enterprise Objects (ZEO) database sharing is enabled, allows remote attackers to execute arbitrary Python code via vectors involving the ZEO network protocol.
O3 Security · Impact-Aware SCA

Is GHSA-4x83-5gw5-q346 in your dependencies?

Find it across PyPI, including transitive dependencies.

Zope Object Database (ZODB) vulnerable to arbitrary…