NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
Withdrawn — this advisory has been retracted
📦
📦 Debian:10
Not in CISA KEV
CRITICAL severity

CVE-2009-0668 — zodb

CRITICAL

CVE-2009-0668 is a critical-severity (CVSS 9.8) Code Injection vulnerability in zodb. A fix is available for zodb — see the affected versions and patch details below.

Zope Object Database (ZODB) vulnerable to arbitrary Python code execution in ZEO storage servers

Also known asGHSA-4x83-5gw5-q346PYSEC-2009-8
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
0.14%0.98%1.82%2.66%0.6%2.2%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
📦zodb

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Debian:10 packages — download data is not available via public APIs for these ecosystems.

Description

Unspecified vulnerability in Zope Object Database (ZODB) before 3.8.2, when certain Zope Enterprise Objects (ZEO) database sharing is enabled, allows remote attackers to execute arbitrary Python code via vectors involving the ZEO network protocol.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦Debian:10zodball versions1:3.8.2-1

Affected Products

1 product · 17 configurations
Application
zodbzope
≤ 3.8.1
16 versions
2.8.112.9.112.10.92.11.43.13.1.13.23.2.43.33.3.33.43.4.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zodb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update zodb to 1:3.8.2-1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2009-0668 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Frequently Asked Questions

Unspecified vulnerability in Zope Object Database (ZODB) before 3.8.2, when certain Zope Enterprise Objects (ZEO) database sharing is enabled, allows remote attackers to execute arbitrary Python code via vectors involving the ZEO network protocol.
O3 Security · Impact-Aware SCA

Is CVE-2009-0668 in your dependencies?

Find it across Debian:10, including transitive dependencies.

CVE-2009-0668: zodb — Fixed in 1:3.8.2-1