JSPUI Possible Cross Site Scripting in "Request a Copy" FeatureGHSA-4wm8-c2vv-xrpq
HIGHFix: DSpace/DSpace@28eb815GHSA-4wm8-c2vv-xrpq is a high-severity (CVSS 7.1) Cross-site Scripting (XSS) vulnerability in org.dspace:dspace-jspui. A fix is available for org.dspace:dspace-jspui — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-4wm8-c2vv-xrpq.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.dspace:dspace-jspui☕org.dspace:dspace-jspuiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
The JSPUI "Request a Copy" feature does not properly escape values submitted and stored from the "Request a Copy" form. This means that item requests could be vulnerable to XSS attacks. This vulnerability only impacts the JSPUI.
This vulnerability does NOT impact the XMLUI or 7.x.
Patches
DSpace 6.x:
- Fixed in 6.4 via commit: https://github.com/DSpace/DSpace/commit/503a6af57fd720c37b0d86c34de63baa5dd85819
- 6.x patch file: https://github.com/DSpace/DSpace/commit/503a6af57fd720c37b0d86c34de63baa5dd85819.patch (may be applied manually if an immediate upgrade to 6.4 is not possible)
DSpace 5.x:
- Fixed in 5.11 via commit: https://github.com/DSpace/DSpace/commit/28eb8158210d41168a62ed5f9e044f754513bc37
- 5.x patch file: https://github.com/DSpace/DSpace/commit/28eb8158210d41168a62ed5f9e044f754513bc37.patch (may be applied manually if an immediate upgrade to 5.11 or 6.4 is not possible)
Apply the patch to your DSpace
If at all possible, we recommend upgrading your DSpace site based on the upgrade instructions. However, if you are unable to do so, you can manually apply the above patches as follows:
- Download the appropriate patch file to the machine where DSpace is running
- From the
[dspace-src]folder, apply the patch, e.g.git apply [name-of-file].patch - Now, update your DSpace site (based loosely on the Upgrade instructions). This generally involves three steps:
- Rebuild DSpace, e.g.
mvn -U clean package(This will recompile all DSpace code) - Redeploy DSpace, e.g.
ant update(This will copy all updated WARs / configs to your installation directory). Depending on your setup you also may need to copy the updated WARs over to your Tomcat webapps folder. - Restart Tomcat
- Rebuild DSpace, e.g.
Workarounds
As a workaround, you can temporarily disable the "Request a Copy" feature by either commenting out the below configuration (or setting its value to empty):
# Comment out this default value
# request.item.type = all
Once your JSPUI site is patched, you can re-enable this setting. See https://wiki.lyrasis.org/display/DSDOC6x/Request+a+Copy for more information on this setting.
References
Discovered & reported by Andrea Bollini of 4Science
For more information
If you have any questions or comments about this advisory:
- Email us at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.dspace:dspace-jspui | ≥ 5.0&&< 5.11 | 5.11org.dspace:dspace-jspui:5.11 |
| ☕Maven | org.dspace:dspace-jspui | ≥ 6.0&&< 6.4 | 6.4org.dspace:dspace-jspui:6.4 |
Affected Products
dspaceduraspaceDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.dspace:dspace-jspui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.dspace:dspace-jspui to 5.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4wm8-c2vv-xrpq is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-4wm8-c2vv-xrpq in your dependencies?
Find it across Maven, including transitive dependencies.