NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

MantisBT vulnerable to XSS through config_option parameter in adm_config_report.phpGHSA-4w6c-3hcx-rfj5

MEDIUMFix: mantisbt/mantisbt@0243375

GHSA-4w6c-3hcx-rfj5 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in mantisbt/mantisbt. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for mantisbt/mantisbt — see the affected versions and patch details below.

Also known asCVE-2017-7309
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
57.3%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
0.00%24.8%49.5%74.3%2.5%57.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘mantisbt/mantisbt🐘mantisbt/mantisbt🐘mantisbt/mantisbt

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page (adm_config_report.php) allows remote attackers to inject arbitrary code (if CSP settings permit it) through a crafted 'config_option' parameter. This is fixed in 1.3.9, 2.1.3, and 2.2.3.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmantisbt/mantisbtall versions1.3.9composer require mantisbt/mantisbt:^1.3.9
🐘Packagistmantisbt/mantisbt≥ 2.1.0&&< 2.1.32.1.3composer require mantisbt/mantisbt:^2.1.3
🐘Packagistmantisbt/mantisbt≥ 2.2.0&&< 2.2.32.2.3composer require mantisbt/mantisbt:^2.2.3

Affected Products

1 product · 24 configurations
Application
mantisbtmantisbt
19 versions
1.3.01.3.11.3.21.3.31.3.41.3.51.3.61.3.71.3.81.3.92.0.02.0.1
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mantisbt/mantisbt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mantisbt/mantisbt to 1.3.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4w6c-3hcx-rfj5 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page (adm_config_report.php) allows remote attackers to inject arbitrary code (if CSP settings permit it) through a crafted 'config_option' parameter. This is fixed in 1.3.9, 2.1.3, and 2.2.3.
O3 Security · Impact-Aware SCA

Is GHSA-4w6c-3hcx-rfj5 in your dependencies?

Find it across Packagist, including transitive dependencies.

MantisBT vulnerable to XSS through config_option…