NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Arbitrary File Read in Snyk BrokerGHSA-4vj3-f849-5r48

MEDIUM

GHSA-4vj3-f849-5r48 is a medium-severity (CVSS 6.5) CWE-59 vulnerability in snyk-broker. A fix is available for snyk-broker — see the affected versions and patch details below.

Also known asCVE-2020-7653SNYK-JS-SNYKBROKER-570612
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs67th percentile — riskier than 67% of all scored CVEsHighest risk
0.00%0.54%1.09%1.63%0.4%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

1other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
snyk-brokernpm
457downloads / week

Description

All versions of snyk-broker before 4.80.0 are vulnerable to Arbitrary File Read. It allows arbitrary file reads for users with access to Snyk's internal network by creating symlinks to match whitelisted paths.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmsnyk-brokerall versions4.80.0npm install snyk-broker@4.80.0

Affected Products

1 product · 1 configurations
Application
brokersynk
< 4.80.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for snyk-broker, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update snyk-broker to 4.80.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4vj3-f849-5r48 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

All versions of snyk-broker before 4.80.0 are vulnerable to Arbitrary File Read. It allows arbitrary file reads for users with access to Snyk's internal network by creating symlinks to match whitelisted paths.
O3 Security · Impact-Aware SCA

Is GHSA-4vj3-f849-5r48 in your dependencies?

Find it across npm, including transitive dependencies.

Arbitrary File Read in Snyk Broker (Medium 6.5)