NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2020-7654 — snyk-broker

HIGH

CVE-2020-7654 is a high-severity (CVSS 7.5) CWE-532 vulnerability in snyk-broker. A fix is available for snyk-broker — see the affected versions and patch details below.

Information Exposure in Snyk Broker

Also known asGHSA-mgh5-4h95-qj4pSNYK-JS-SNYKBROKER-570613
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs66th percentile — riskier than 66% of all scored CVEsHighest risk
0.00%0.54%1.08%1.62%0.3%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

1other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
snyk-brokernpm
955downloads / week

Description

All versions of snyk-broker before 4.73.1 are vulnerable to Information Exposure. It logs private keys if logging level is set to DEBUG.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmsnyk-brokerall versions4.73.1npm install snyk-broker@4.73.1

Affected Products

1 product · 1 configurations
Application
brokersynk
< 4.73.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for snyk-broker, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update snyk-broker to 4.73.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-7654 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

All versions of snyk-broker before 4.73.1 are vulnerable to Information Exposure. It logs private keys if logging level is set to DEBUG.
O3 Security · Impact-Aware SCA

Is CVE-2020-7654 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2020-7654: snyk-broker — Fixed in 4.73.1