NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🦀
🦀 crates.io
Not in CISA KEV
MEDIUM severity

Memory over-allocation in evm crateGHSA-4jwq-572w-4388

MEDIUMFix: rust-blockchain/evm@19ade85

GHSA-4jwq-572w-4388 is a medium-severity (CVSS 6.5) CWE-770 vulnerability in evm. A fix is available for evm — see the affected versions and patch details below.

Also known asCVE-2021-29511
Published
Updated
Affected
12 pkgs
Patched
12 / 12
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs70th percentile — riskier than 70% of all scored CVEsHighest risk
0.00%0.59%1.19%1.78%0.4%1.3%May 26Oct 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

12 pkgs affected
🦀evm🦀evm-core🦀evm🦀evm🦀evm🦀evm🦀evm🦀evm-core+4 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Prior to the patch, when executing specific EVM opcodes related to memory operations that use evm_core::Memory::copy_large, the crate can over-allocate memory when it is not needed, making it possible for an attacker to perform denial-of-service attack.

Patches

The flaw was corrected in commit 19ade85. Users should upgrade to ==0.21.1, ==0.23.1, ==0.24.1, ==0.25.1, >=0.26.1.

Workarounds

None. Please upgrade your evm crate version

References

Fix commit: https://github.com/rust-blockchain/evm/commit/19ade858c430ab13eb562764a870ac9f8506f8dd

For more information

If you have any questions or comments about this advisory:

Affected Packages

12 total 12 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.ioevmall versions0.21.1cargo update -p evm --precise 0.21.1
🦀crates.ioevm-coreall versions0.21.1cargo update -p evm-core --precise 0.21.1
🦀crates.ioevm≥ 0.22.0&&< 0.22.10.22.1cargo update -p evm --precise 0.22.1
🦀crates.ioevm≥ 0.23.0&&< 0.23.10.23.1cargo update -p evm --precise 0.23.1
🦀crates.ioevm≥ 0.24.0&&< 0.24.10.24.1cargo update -p evm --precise 0.24.1
🦀crates.ioevm≥ 0.25.0&&< 0.25.10.25.1cargo update -p evm --precise 0.25.1

Affected Products

1 product · 6 configurations
Application
evmevm_project
≤ 0.21.0
5 versions
0.22.00.23.00.24.00.25.00.26.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for evm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update evm to 0.21.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4jwq-572w-4388 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

### Impact Prior to the patch, when executing specific EVM opcodes related to memory operations that use `evm_core::Memory::copy_large`, the crate can over-allocate memory when it is not needed, making it possible for an attacker to perform denial-of-service attack. ### Patches The flaw was corrected in commit `19ade85`. Users should upgrade to `==0.21.1, ==0.23.1, ==0.24.1, ==0.25.1, >=0.26.1`. ### Workarounds None. Please upgrade your `evm` crate version ### References Fix commit: https://github.com/rust-blockchain/evm/commit/19ade858c430ab13eb562764a870ac9f8506f8dd ### For more informat
O3 Security · Impact-Aware SCA

Is GHSA-4jwq-572w-4388 in your dependencies?

Find it across crates.io, including transitive dependencies.

Memory over-allocation in evm crate (Medium 6.5)