CVE-2021-29511 is a medium-severity (CVSS 6.5) CWE-770 vulnerability in evm. A fix is available for evm — see the affected versions and patch details below.
Memory over-allocation in evm crate
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
evm🦀evm-core🦀evm🦀evm🦀evm🦀evm🦀evm🦀evm-core+4 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Prior to the patch, when executing specific EVM opcodes related to memory operations that use evm_core::Memory::copy_large, the crate can over-allocate memory when it is not needed, making it possible for an attacker to perform denial-of-service attack.
Patches
The flaw was corrected in commit 19ade85. Users should upgrade to ==0.21.1, ==0.23.1, ==0.24.1, ==0.25.1, >=0.26.1.
Workarounds
None. Please upgrade your evm crate version
References
Fix commit: https://github.com/rust-blockchain/evm/commit/19ade858c430ab13eb562764a870ac9f8506f8dd
For more information
If you have any questions or comments about this advisory:
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | evm | all versions | 0.21.1cargo update -p evm --precise 0.21.1 |
| 🦀crates.io | evm-core | all versions | 0.21.1cargo update -p evm-core --precise 0.21.1 |
| 🦀crates.io | evm | ≥ 0.22.0&&< 0.22.1 | 0.22.1cargo update -p evm --precise 0.22.1 |
| 🦀crates.io | evm | ≥ 0.23.0&&< 0.23.1 | 0.23.1cargo update -p evm --precise 0.23.1 |
| 🦀crates.io | evm | ≥ 0.24.0&&< 0.24.1 | 0.24.1cargo update -p evm --precise 0.24.1 |
| 🦀crates.io | evm | ≥ 0.25.0&&< 0.25.1 | 0.25.1cargo update -p evm --precise 0.25.1 |
Affected Products
evmevm_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for evm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update evm to 0.21.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-29511 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2021-29511 in your dependencies?
Find it across crates.io, including transitive dependencies.