NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

AWS Advanced Python Wrapper: Privilege Escalation in Aurora PostgreSQL instanceGHSA-4jvf-wx3f-2x8q

HIGHFix: aws/aws-advanced-python-wrapper#1007

GHSA-4jvf-wx3f-2x8q is a high-severity (CVSS 8) CWE-470 vulnerability in aws-advanced-python-wrapper. A fix is available for aws-advanced-python-wrapper — see the affected versions and patch details below.

Also known asCVE-2025-12967PYSEC-2026-1205
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-4jvf-wx3f-2x8q.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs56th percentile — riskier than 56% of all scored CVEsHighest risk
0.00%0.43%0.85%1.28%0.2%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍aws-advanced-python-wrapper

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Description of Vulnerability:

An issue in AWS Wrappers for Amazon Aurora PostgreSQL may allow for privilege escalation to rds_superuser role. A low privilege authenticated user can create a crafted function that could be executed with permissions of other Amazon Relational Database Service (RDS) users.

AWS recommends customers upgrade to the following versions: AWS Python Wrapper to v1.4.0

Source of Vulnerability Report:

Allistair Ishmael Hakim [email protected]

Affected products & versions:

AWS Python Wrapper < 1.4.0

Platforms:

MacOS/Windows/Linux

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIaws-advanced-python-wrapperall versions1.4.0pip install --upgrade 'aws-advanced-python-wrapper==1.4.0'

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for aws-advanced-python-wrapper, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update aws-advanced-python-wrapper to 1.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4jvf-wx3f-2x8q is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

### Description of Vulnerability: An issue in AWS Wrappers for Amazon Aurora PostgreSQL may allow for privilege escalation to rds_superuser role. A low privilege authenticated user can create a crafted function that could be executed with permissions of other Amazon Relational Database Service (RDS) users. AWS recommends customers upgrade to the following versions: AWS Python Wrapper to v1.4.0 ### Source of Vulnerability Report: Allistair Ishmael Hakim <[email protected]> ### Affected products & versions: AWS Python Wrapper < 1.4.0 ### Platforms: MacOS/Windows/Linux
O3 Security · Impact-Aware SCA

Is GHSA-4jvf-wx3f-2x8q in your dependencies?

Find it across PyPI, including transitive dependencies.

AWS Advanced Python Wrapper: Privilege Escalation in…