NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

Knex.js has a limited SQL injection vulnerabilityGHSA-4jv9-3563-23j3

HIGHFix: knex/knex#5417

GHSA-4jv9-3563-23j3 is a high-severity (CVSS 7.5) SQL Injection vulnerability in knex. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for knex — see the affected versions and patch details below.

Also known asCVE-2016-20018
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs66th percentile — riskier than 66% of all scored CVEsHighest risk
0.00%0.54%1.08%1.62%0.1%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

5Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
knexnpm
6.8Mdownloads / week

Description

Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query. This vulnerability has been fixed in version 2.4.0.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmknexall versions2.4.0npm install knex@2.4.0

Affected Products

1 product · 1 configurations
Application
knexknexjs
≤ 2.3.0
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for knex, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update knex to 2.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4jv9-3563-23j3 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query. This vulnerability has been fixed in version 2.4.0.
O3 Security · Impact-Aware SCA

Is GHSA-4jv9-3563-23j3 in your dependencies?

Find it across npm, including transitive dependencies.

Knex.js has a limited SQL injection vulnerability (High 7.5)