NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2019-10757 — knex

CRITICAL

CVE-2019-10757 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in knex. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for knex — see the affected versions and patch details below.

SQL Injection in knex

Also known asGHSA-58v4-qwx5-7f59SNYK-JS-KNEX-471962
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs67th percentile — riskier than 67% of all scored CVEsHighest risk
0.00%0.55%1.11%1.66%0.3%1.2%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

5Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
knexnpm
7.2Mdownloads / week

Description

knex.js versions before 0.19.5 are vulnerable to SQL Injection attack. Identifiers are escaped incorrectly as part of the MSSQL dialect, allowing attackers to craft a malicious query to the host DB.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmknexall versions0.19.5npm install knex@0.19.5

Affected Products

1 product · 1 configurations
Application
knexknexjs
< 0.19.5
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for knex, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update knex to 0.19.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10757 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

knex.js versions before 0.19.5 are vulnerable to SQL Injection attack. Identifiers are escaped incorrectly as part of the MSSQL dialect, allowing attackers to craft a malicious query to the host DB.
O3 Security · Impact-Aware SCA

Is CVE-2019-10757 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2019-10757: knex SQL Injection — Fixed in 0.19.5