NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

silverstripe/framework vulnerable to Cross-site Scripting In `OptionsetField` and `CheckboxSetField`GHSA-468j-6jrc-2rjx

MEDIUMFix: silverstripe/silverstripe-framework@049cdef

GHSA-468j-6jrc-2rjx is a medium-severity (CVSS 6.1) vulnerability in silverstripe/framework. A fix is available for silverstripe/framework — see the affected versions and patch details below.

Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Dec 2, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

4 pkgs affected
🐘silverstripe/framework🐘silverstripe/framework🐘silverstripe/framework🐘silverstripe/framework

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

List of key / value pairs assigned to OptionsetField or CheckboxSetField do not have a default casting assigned to them. The effect of this is a potential XSS vulnerability in lists where either key or value contain unescaped HTML.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsilverstripe/framework≥ 3.1.19-rc1&&< 3.1.203.1.20composer require silverstripe/framework:^3.1.20
🐘Packagistsilverstripe/framework≥ 3.2.4-rc1&&< 3.2.53.2.5composer require silverstripe/framework:^3.2.5
🐘Packagistsilverstripe/framework≥ 3.3.2-rc1&&< 3.3.33.3.3composer require silverstripe/framework:^3.3.3
🐘Packagistsilverstripe/framework≥ 3.4.0-rc1&&< 3.4.13.4.1composer require silverstripe/framework:^3.4.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update silverstripe/framework to 3.1.20 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-468j-6jrc-2rjx is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

List of key / value pairs assigned to `OptionsetField` or `CheckboxSetField` do not have a default casting assigned to them. The effect of this is a potential XSS vulnerability in lists where either key or value contain unescaped HTML.
O3 Security · Impact-Aware SCA

Is GHSA-468j-6jrc-2rjx in your dependencies?

Find it across Packagist, including transitive dependencies.

silverstripe/framework vulnerable to Cross-site Scripting…