AnyIO run_process/open_process ignores extra_groups and can retain parent supplementary groupsGHSA-3w57-8xmc-8v26
Fix: agronholm/anyio#1209GHSA-3w57-8xmc-8v26 is a CWE-266 vulnerability in anyio. A fix is available for anyio — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-3w57-8xmc-8v26.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
anyioReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
AnyIO 4.14.0 accepts the POSIX extra_groups argument on anyio.run_process() and anyio.open_process(), but open_process() forwards the wrong variable to the backend: when extra_groups is not None, it assigns kwargs["extra_groups"] = group instead of extra_groups. As a result, callers cannot reliably clear or set supplementary groups for child processes. In a disposable Linux container, Python's subprocess.run(..., extra_groups=[]) clears a synthetic parent supplementary group list, while anyio.run_process(..., extra_groups=[]) preserves the parent groups. If group is also supplied, AnyIO passes an integer as extra_groups and the call fails with TypeError. This is a POSIX privilege-dropping correctness issue for applications that rely on AnyIO subprocess helpers to launch less-privileged child processes.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | anyio | ≥ 4.14.0&&< 4.14.2 | 4.14.2pip install --upgrade 'anyio==4.14.2' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for anyio, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update anyio to 4.14.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-3w57-8xmc-8v26 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
A MODERATE severity flaw was found in AnyIO, a Python asynchronous concurrency and networking library shipped in Red Hat products including Red Hat OpenStack Platform, Red Hat OpenShift AI, and Red Hat Satellite. On POSIX systems, anyio.run_process() and anyio.open_process() accept the extra_groups argument, but…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability. The upstream project fixed this issue in AnyIO 4.14.2; updates for the affected Red Hat product streams are deferred because this flaw is rated MODERATE severity.Source: Red Hat security advisory for GHSA-3w57-8xmc-8v26 (CC BY 4.0)
Frequently Asked Questions
Is GHSA-3w57-8xmc-8v26 in your dependencies?
Find it across PyPI, including transitive dependencies.