NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

Moderate severity vulnerability that affects org.apache.hadoop:hadoop-mainGHSA-3v44-382q-55f4

MEDIUM

GHSA-3v44-382q-55f4 is a medium-severity (CVSS 6.5) Information Exposure vulnerability in org.apache.hadoop:hadoop-main. A fix is available for org.apache.hadoop:hadoop-main — see the affected versions and patch details below.

Also known asCVE-2017-15713
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.00%0.94%1.88%2.82%0.3%2.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.hadoop:hadoop-main☕org.apache.hadoop:hadoop-main

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Vulnerability in Apache Hadoop 0.23.x, 2.x before 2.7.5, 2.8.x before 2.8.3, and 3.0.0-alpha through 3.0.0-beta1 allows a cluster user to expose private files owned by the user running the MapReduce job history server process. The malicious user can construct a configuration file containing XML directives that reference sensitive files on the MapReduce job history server host.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.hadoop:hadoop-mainall versions2.7.5org.apache.hadoop:hadoop-main:2.7.5
☕Mavenorg.apache.hadoop:hadoop-main≥ 2.8.0&&< 2.8.32.8.3org.apache.hadoop:hadoop-main:2.8.3

Affected Products

1 product · 16 configurations
Application
hadoopapache
≥ 2.2.0 && ≤ 2.8.2
10 versions
2.0.02.0.12.0.22.0.32.0.42.0.52.0.62.1.02.1.13.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.hadoop:hadoop-main, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.hadoop:hadoop-main to 2.7.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-3v44-382q-55f4 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

Vulnerability in Apache Hadoop 0.23.x, 2.x before 2.7.5, 2.8.x before 2.8.3, and 3.0.0-alpha through 3.0.0-beta1 allows a cluster user to expose private files owned by the user running the MapReduce job history server process. The malicious user can construct a configuration file containing XML directives that reference sensitive files on the MapReduce job history server host.
O3 Security · Impact-Aware SCA

Is GHSA-3v44-382q-55f4 in your dependencies?

Find it across Maven, including transitive dependencies.

Moderate severity vulnerability that affects…