CVE-2017-15713 — hadoop-main
MEDIUMCVE-2017-15713 is a medium-severity (CVSS 6.5) Information Exposure vulnerability in org.apache.hadoop:hadoop-main. A fix is available for org.apache.hadoop:hadoop-main — see the affected versions and patch details below.
Moderate severity vulnerability that affects org.apache.hadoop:hadoop-main
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.hadoop:hadoop-main☕org.apache.hadoop:hadoop-mainReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Vulnerability in Apache Hadoop 0.23.x, 2.x before 2.7.5, 2.8.x before 2.8.3, and 3.0.0-alpha through 3.0.0-beta1 allows a cluster user to expose private files owned by the user running the MapReduce job history server process. The malicious user can construct a configuration file containing XML directives that reference sensitive files on the MapReduce job history server host.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.hadoop:hadoop-main | all versions | 2.7.5org.apache.hadoop:hadoop-main:2.7.5 |
| ☕Maven | org.apache.hadoop:hadoop-main | ≥ 2.8.0&&< 2.8.3 | 2.8.3org.apache.hadoop:hadoop-main:2.8.3 |
Affected Products
hadoopapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.hadoop:hadoop-main, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.hadoop:hadoop-main to 2.7.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-15713 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2017-15713 in your dependencies?
Find it across Maven, including transitive dependencies.