NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

Bolt Cross Site Request Forgery (CSRF)GHSA-3g6c-88pf-m46f

HIGHFix: bolt/bolt#7768

GHSA-3g6c-88pf-m46f is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in bolt/bolt. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for bolt/bolt — see the affected versions and patch details below.

Also known asCVE-2019-10874
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
4 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
0.00%1.92%3.84%5.76%0.4%4.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘bolt/bolt

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross Site Request Forgery (CSRF) in the bolt/upload File Upload feature in Bolt CMS 3.6.6 allows remote attackers to execute arbitrary code by uploading a JavaScript file to include executable extensions in the file/edit/config/config.yml configuration file.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistbolt/bolt≥ 3.6.6&&< 3.6.73.6.7composer require bolt/bolt:^3.6.7

Affected Products

1 product · 1 configurations
Application
boltboltcms
1 version
3.6.6
Exploits & PoCs
4

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-46664webappsphp

Bolt CMS 3.6.6 - Cross-Site Request Forgery / Remote Code Execution

by FelipeGaspar · Apr 8, 2019

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for bolt/bolt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update bolt/bolt to 3.6.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-3g6c-88pf-m46f is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Cross Site Request Forgery (CSRF) in the `bolt/upload` File Upload feature in Bolt CMS 3.6.6 allows remote attackers to execute arbitrary code by uploading a JavaScript file to include executable extensions in the `file/edit/config/config.yml` configuration file.
O3 Security · Impact-Aware SCA

Is GHSA-3g6c-88pf-m46f in your dependencies?

Find it across Packagist, including transitive dependencies.

Bolt Cross Site Request Forgery (CSRF) (High 8.8)