CVE-2019-10874 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in bolt/bolt. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for bolt/bolt — see the affected versions and patch details below.
Bolt Cross Site Request Forgery (CSRF)
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
bolt/boltReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross Site Request Forgery (CSRF) in the bolt/upload File Upload feature in Bolt CMS 3.6.6 allows remote attackers to execute arbitrary code by uploading a JavaScript file to include executable extensions in the file/edit/config/config.yml configuration file.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | bolt/bolt | ≥ 3.6.6&&< 3.6.7 | 3.6.7composer require bolt/bolt:^3.6.7 |
Affected Products
boltboltcmsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Bolt CMS 3.6.6 - Cross-Site Request Forgery / Remote Code Execution
by FelipeGaspar · Apr 8, 2019
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for bolt/bolt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update bolt/bolt to 3.6.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10874 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2019-10874 in your dependencies?
Find it across Packagist, including transitive dependencies.