NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

Magento Open Source Improper Input Validation vulnerabilityGHSA-3fr3-gcqh-3m2g

HIGH

GHSA-3fr3-gcqh-3m2g is a high-severity (CVSS 7.6) Improper Input Validation vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.

Also known asCVE-2024-45117
Published
Updated
Affected
8 pkgs
Patched
4 / 8
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-3fr3-gcqh-3m2g.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.90%1.35%0.3%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

8 pkgs affected
🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Magento Open Source versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by an Improper Input Validation vulnerability that could lead to arbitrary file system read. An admin attacker could exploit this vulnerability to read files from the system outside of the intended directories via PHP filter chain and also can have a low-availability impact on the service. Exploitation of this issue does not require user interaction and scope is changed.

Affected Packages

8 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/community-edition≥ 2.4.7-beta1&&< 2.4.7-p32.4.7-p3composer require magento/community-edition:^2.4.7-p3
🐘Packagistmagento/community-edition≥ 2.4.6-p1&&< 2.4.6-p82.4.6-p8composer require magento/community-edition:^2.4.6-p8
🐘Packagistmagento/community-edition≥ 2.4.5-p1&&< 2.4.5-p102.4.5-p10composer require magento/community-edition:^2.4.5-p10
🐘Packagistmagento/community-editionall versions2.4.4-p11composer require magento/community-edition:^2.4.4-p11
🐘Packagistmagento/community-editionall versionsNo fix
🐘Packagistmagento/community-editionall versionsNo fix

Affected Products

3 products · 116 configurations
Application
commerceadobe
9 versions
2.3.72.4.02.4.12.4.22.4.32.4.42.4.52.4.62.4.7
Application
commerce b2badobe
4 versions
1.3.31.3.41.3.51.4.2
Application
magentoadobe
5 versions
2.4.32.4.42.4.52.4.62.4.7

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update magento/community-edition to 2.4.7-p3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-3fr3-gcqh-3m2g is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Magento Open Source versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by an Improper Input Validation vulnerability that could lead to arbitrary file system read. An admin attacker could exploit this vulnerability to read files from the system outside of the intended directories via PHP filter chain and also can have a low-availability impact on the service. Exploitation of this issue does not require user interaction and scope is changed.
O3 Security · Impact-Aware SCA

Is GHSA-3fr3-gcqh-3m2g in your dependencies?

Find it across Packagist, including transitive dependencies.

Magento Open Source Improper Input Validation…