CVE-2024-45117 — community-edition
HIGHCVE-2024-45117 is a high-severity (CVSS 7.6) Improper Input Validation vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.
Adobe Commerce | Improper Input Validation (CWE-20)
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-45117.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-editionReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Magento Open Source versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by an Improper Input Validation vulnerability that could lead to arbitrary file system read. An admin attacker could exploit this vulnerability to read files from the system outside of the intended directories via PHP filter chain and also can have a low-availability impact on the service. Exploitation of this issue does not require user interaction and scope is changed.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | magento/community-edition | ≥ 2.4.7-beta1&&< 2.4.7-p3 | 2.4.7-p3composer require magento/community-edition:^2.4.7-p3 |
| 🐘Packagist | magento/community-edition | ≥ 2.4.6-p1&&< 2.4.6-p8 | 2.4.6-p8composer require magento/community-edition:^2.4.6-p8 |
| 🐘Packagist | magento/community-edition | ≥ 2.4.5-p1&&< 2.4.5-p10 | 2.4.5-p10composer require magento/community-edition:^2.4.5-p10 |
| 🐘Packagist | magento/community-edition | all versions | 2.4.4-p11composer require magento/community-edition:^2.4.4-p11 |
| 🐘Packagist | magento/community-edition | all versions | No fix |
| 🐘Packagist | magento/community-edition | all versions | No fix |
Affected Products
commerceadobecommerce b2badobemagentoadobeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update magento/community-edition to 2.4.7-p3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-45117 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-45117 in your dependencies?
Find it across Packagist, including transitive dependencies.