NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Drupal Core Potential Cross-Site Scripting (XSS) via Error MessagesGHSA-39g6-x4x8-5jcm

MEDIUM

GHSA-39g6-x4x8-5jcm is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.

Also known asBIT-drupal-2025-3057CVE-2025-3057DRUPAL-CORE-2025-001
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-39g6-x4x8-5jcm.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs24th percentile — riskier than 24% of all scored CVEsHighest risk
0.00%0.30%0.60%0.91%0.4%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘drupal/core🐘drupal/core🐘drupal/core🐘drupal/core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS).This issue affects Drupal core: from 8.0.0 before 10.3.13, from 10.4.0 before 10.4.3, from 11.0.0 before 11.0.12, from 11.1.0 before 11.1.3.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdrupal/core≥ 8.0.0&&< 10.3.1310.3.13composer require drupal/core:^10.3.13
🐘Packagistdrupal/core≥ 10.4.0&&< 10.4.310.4.3composer require drupal/core:^10.4.3
🐘Packagistdrupal/core≥ 11.0.0&&< 11.0.1211.0.12composer require drupal/core:^11.0.12
🐘Packagistdrupal/core≥ 11.1.0&&< 11.1.311.1.3composer require drupal/core:^11.1.3

Affected Products

1 product · 4 configurations
Application
drupaldrupal
≥ 11.1.0 && < 11.1.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update drupal/core to 10.3.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-39g6-x4x8-5jcm is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS).This issue affects Drupal core: from 8.0.0 before 10.3.13, from 10.4.0 before 10.4.3, from 11.0.0 before 11.0.12, from 11.1.0 before 11.1.3.
O3 Security · Impact-Aware SCA

Is GHSA-39g6-x4x8-5jcm in your dependencies?

Find it across Packagist, including transitive dependencies.

Drupal Core Potential Cross-Site Scripting (XSS) via Error…