PrestaShop has multiple stored XSS vulnerabilities via unprotected Template variablesGHSA-35pf-37c6-jxjv
HIGHGHSA-35pf-37c6-jxjv is a high-severity (CVSS 7.6) Cross-site Scripting (XSS) vulnerability in prestashop/prestashop. A fix is available for prestashop/prestashop — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-35pf-37c6-jxjv.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
prestashop/prestashop🐘prestashop/prestashopReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
PrestaShop is an open source e-commerce web application. Versions prior to 8.2.5 and 9.1.0 are vulnerable to stored Cross-Site Scripting (stored XSS) vulnerabilities in the BO. An attacker who can inject data into the database, via limited back-office access or a previously existing vulnerability, can exploit unprotected variables in back-office templates. Versions 8.2.5 and 9.1.0 contain a fix. No known workarounds are available.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | prestashop/prestashop | ≥ 9.0.0-alpha.1&&< 9.1.0 | 9.1.0composer require prestashop/prestashop:^9.1.0 |
| 🐘Packagist | prestashop/prestashop | all versions | 8.2.5composer require prestashop/prestashop:^8.2.5 |
Affected Products
prestashopprestashopDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for prestashop/prestashop, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update prestashop/prestashop to 9.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-35pf-37c6-jxjv is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-35pf-37c6-jxjv in your dependencies?
Find it across Packagist, including transitive dependencies.