NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Path disclosure in JavaScript variableGHSA-3366-9287-7qpr

MEDIUMFix: PrestaShop/PrestaShop@444bd0d

GHSA-3366-9287-7qpr is a medium-severity (CVSS 5.8) Path Traversal vulnerability in prestashop/prestashop. A fix is available for prestashop/prestashop — see the affected versions and patch details below.

Also known asCVE-2024-26129
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-3366-9287-7qpr.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs49th percentile — riskier than 49% of all scored CVEsHighest risk
0.00%0.37%0.74%1.11%0.3%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘prestashop/prestashop

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

PrestaShop is an open-source e-commerce platform. Starting in version 8.1.0 and prior to version 8.1.4, PrestaShop is vulnerable to path disclosure in a JavaScript variable. A patch is available in version 8.1.4.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistprestashop/prestashop≥ 8.1.0&&< 8.1.48.1.4composer require prestashop/prestashop:^8.1.4

Affected Products

1 product · 1 configurations
Application
prestashopprestashop
≥ 8.1.0 && < 8.1.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for prestashop/prestashop, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update prestashop/prestashop to 8.1.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-3366-9287-7qpr is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

### Impact Path disclosure in JavaScript variable ### Patches Patch in PrestaShop 8.1.4 ### References https://owasp.org/www-community/attacks/Full_Path_Disclosure Thanks to https://github.com/hugo-fasone
O3 Security · Impact-Aware SCA

Is GHSA-3366-9287-7qpr in your dependencies?

Find it across Packagist, including transitive dependencies.

Path disclosure in JavaScript variable (Medium 5.8)