Subrion Cross-site scripting (XSS) vulnerabilityGHSA-2xv7-fwh6-x7fc
MEDIUMGHSA-2xv7-fwh6-x7fc is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in intelliants/subrion. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for intelliants/subrion — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
intelliants/subrionReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in Subrion CMS 4.1.4 allows remote attackers to inject arbitrary web script or HTML via the body to blog/add/, a different vulnerability than CVE-2017-6069.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | intelliants/subrion | all versions | 4.1.6composer require intelliants/subrion:^4.1.6 |
Affected Products
subrionintelliantsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for intelliants/subrion, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update intelliants/subrion to 4.1.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2xv7-fwh6-x7fc is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-2xv7-fwh6-x7fc in your dependencies?
Find it across Packagist, including transitive dependencies.