NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2017-10795 — subrion

MEDIUM

CVE-2017-10795 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in intelliants/subrion. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for intelliants/subrion — see the affected versions and patch details below.

Subrion Cross-site scripting (XSS) vulnerability

Also known asGHSA-2xv7-fwh6-x7fc
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs66th percentile — riskier than 66% of all scored CVEsHighest risk
0.00%0.54%1.09%1.63%0.3%1.1%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘intelliants/subrion

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in Subrion CMS 4.1.4 allows remote attackers to inject arbitrary web script or HTML via the body to blog/add/, a different vulnerability than CVE-2017-6069.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistintelliants/subrionall versions4.1.6composer require intelliants/subrion:^4.1.6

Affected Products

1 product · 1 configurations
Application
subrionintelliants
1 version
4.1.4
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for intelliants/subrion, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update intelliants/subrion to 4.1.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-10795 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in Subrion CMS 4.1.4 allows remote attackers to inject arbitrary web script or HTML via the body to blog/add/, a different vulnerability than CVE-2017-6069.
O3 Security · Impact-Aware SCA

Is CVE-2017-10795 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-10795: subrion XSS — Fixed in 4.1.6