GHSA-2p9h-rqjw-gm92 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in n8n. A fix is available for n8n — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
n8nnpmDescription
Impact
An authenticated user with permission to create or modify workflows could inject arbitrary scripts into pages rendered by the n8n application using different techniques on various nodes (Form Trigger node, Chat Trigger node, Send & Wait node, Webhook Node, and Chat Node). Scripts injected by a malicious workflow execute in the browser of any user who visits the affected page, enabling session hijacking and account takeover.
Patches
The issues have been fixed in n8n versions 2.10.1, 2.9.3, and 1.123.22. Users should upgrade to one of these versions or later to remediate the vulnerability.
Workarounds
If upgrading is not immediately possible, administrators should consider the following temporary mitigations:
- Limit workflow creation and editing permissions to fully trusted users only.
- Disable the Webhook node by adding
n8n-nodes-base.webhookto theNODES_EXCLUDEenvironment variable.
These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
Credit
Reporters:
- @ori-ron
- @Aikido-Security
- @nil340
- Pawel Bednarz from the NATO Cyber Security Centre (NCSC)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | n8n | all versions | 1.123.22npm install n8n@1.123.22 |
| 📦npm | n8n | ≥ 2.0.0&&< 2.9.3 | 2.9.3npm install n8n@2.9.3 |
| 📦npm | n8n | ≥ 2.10.0&&< 2.10.1 | 2.10.1npm install n8n@2.10.1 |
Affected Products
n8nn8nDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for n8n, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update n8n to 1.123.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2p9h-rqjw-gm92 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-2p9h-rqjw-gm92 in your dependencies?
Find it across npm, including transitive dependencies.