NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

CVE-2026-27578 — n8n

Fix: n8n-io/n8n@062644e

CVE-2026-27578 is a Cross-site Scripting (XSS) vulnerability in n8n. A fix is available for n8n — see the affected versions and patch details below.

n8n Vulnerable to Stored XSS via Various Nodes

Also known asGHSA-2p9h-rqjw-gm92
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk-0.10%
Lower risk than most CVEs13th percentile — riskier than 13% of all scored CVEsHighest risk
0.00%0.27%0.54%0.82%0.0%0.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

3 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

36other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
n8nnpm
160Kdownloads / week

Description

Impact

An authenticated user with permission to create or modify workflows could inject arbitrary scripts into pages rendered by the n8n application using different techniques on various nodes (Form Trigger node, Chat Trigger node, Send & Wait node, Webhook Node, and Chat Node). Scripts injected by a malicious workflow execute in the browser of any user who visits the affected page, enabling session hijacking and account takeover.

Patches

The issues have been fixed in n8n versions 2.10.1, 2.9.3, and 1.123.22. Users should upgrade to one of these versions or later to remediate the vulnerability.

Workarounds

If upgrading is not immediately possible, administrators should consider the following temporary mitigations:

  • Limit workflow creation and editing permissions to fully trusted users only.
  • Disable the Webhook node by adding n8n-nodes-base.webhook to the NODES_EXCLUDE environment variable.

These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Credit

Reporters:

  • @ori-ron
  • @Aikido-Security
  • @nil340
  • Pawel Bednarz from the NATO Cyber Security Centre (NCSC)

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
📦npmn8nall versions1.123.22npm install n8n@1.123.22
📦npmn8n≥ 2.0.0&&< 2.9.32.9.3npm install n8n@2.9.3
📦npmn8n≥ 2.10.0&&< 2.10.12.10.1npm install n8n@2.10.1

Affected Products

1 product · 3 configurations
Application
n8nn8n
≥ 2.10.0 && < 2.10.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for n8n, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update n8n to 1.123.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-27578 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

## Impact An authenticated user with permission to create or modify workflows could inject arbitrary scripts into pages rendered by the n8n application using different techniques on various nodes (Form Trigger node, Chat Trigger node, Send & Wait node, Webhook Node, and Chat Node). Scripts injected by a malicious workflow execute in the browser of any user who visits the affected page, enabling session hijacking and account takeover. ## Patches The issues have been fixed in n8n versions 2.10.1, 2.9.3, and 1.123.22. Users should upgrade to one of these versions or later to remediate the vulner
O3 Security · Impact-Aware SCA

Is CVE-2026-27578 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-27578: n8n — Fixed in 1.123.22