SilverStripe CSV Excel Macro InjectionGHSA-2jvj-mhf2-g99w
MEDIUMGHSA-2jvj-mhf2-g99w is a medium-severity (CVSS 5.5) CWE-74 vulnerability in silverstripe/framework. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for silverstripe/framework — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
silverstripe/framework🐘silverstripe/framework🐘silverstripe/frameworkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
In the CSV export feature of SilverStripe before 3.5.6, 3.6.x before 3.6.3, and 4.x before 4.0.1, it's possible for the output to contain macros and scripts, which may be executed if imported without sanitization into common software (including Microsoft Excel). For example, the CSV data may contain untrusted user input from the "First Name" field of a user's /myprofile page.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | silverstripe/framework | all versions | 3.5.6composer require silverstripe/framework:^3.5.6 |
| 🐘Packagist | silverstripe/framework | ≥ 3.6.0&&< 3.6.3 | 3.6.3composer require silverstripe/framework:^3.6.3 |
| 🐘Packagist | silverstripe/framework | ≥ 4.0.0&&< 4.0.1 | 4.0.1composer require silverstripe/framework:^4.0.1 |
Affected Products
silverstripesilverstripeResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
SilverStripe CMS 3.6.2 - CSV Excel Macro Injection
by Ishaq Mohammed · Dec 26, 2017
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update silverstripe/framework to 3.5.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2jvj-mhf2-g99w is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-2jvj-mhf2-g99w in your dependencies?
Find it across Packagist, including transitive dependencies.