GHSA-2gwj-7jmv-h26r is a critical-severity (CVSS 9.8) SQL Injection vulnerability in django. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for django — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
django🐍django🐍djangoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in Django 2.2 before 2.2.28, 3.2 before 3.2.13, and 4.0 before 4.0.4. QuerySet.annotate(), aggregate(), and extra() methods are subject to SQL injection in column aliases via a crafted dictionary (with dictionary expansion) as the passed **kwargs.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | django | ≥ 2.2&&< 2.2.28 | 2.2.28pip install --upgrade 'django==2.2.28' |
| 🐍PyPI | django | ≥ 3.2&&< 3.2.13 | 3.2.13pip install --upgrade 'django==3.2.13' |
| 🐍PyPI | django | ≥ 4.0&&< 4.0.4 | 4.0.4pip install --upgrade 'django==4.0.4' |
Affected Products
debian linuxdebiandjangodjangoprojectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update django to 2.2.28 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2gwj-7jmv-h26r is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat OpenStack does ship the affected version of Django, however, vulnerability is not exposed in the product as it does not make use of vulnerable code. We may update Django in a future release of OpenStack.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ansible Automation Platform 2.1 for RHEL 8 | automation-controller-0:4.1.2-2.el8ap | RHSA-2022:5702 |
| Red Hat Automation Hub 4.2 for RHEL 7 | python3-django-0:2.2.28-1.el7pc | RHSA-2022:5703 |
| Red Hat OpenStack Platform 16.1 | python-django20-0:2.0.13-18.el8ost | RHSA-2022:8872 |
| Red Hat OpenStack Platform 16.2 | python-django20-0:2.0.13-17.el8ost | RHSA-2022:5115 |
| Red Hat Satellite 6.11 for RHEL 8 | python-django-0:3.2.13-1.el8pc | RHSA-2022:5498 |
| RHUI 4 for RHEL 8 | python-django-0:3.2.13-2.el8ui | RHSA-2022:5602 |
Frequently Asked Questions
Is GHSA-2gwj-7jmv-h26r in your dependencies?
Find it across PyPI, including transitive dependencies.