NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2022-28346 — django

CRITICALFix: django/django@2044dac

CVE-2022-28346 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in django. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for django — see the affected versions and patch details below.

SQL Injection in Django

Also known asBIT-django-2022-28346GHSA-2gwj-7jmv-h26rPYSEC-2022-190
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
3 known
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
18.7%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs97th percentile — riskier than 97% of all scored CVEsHighest risk
0.00%7.89%15.8%23.7%2.0%18.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍django🐍django🐍django

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in Django 2.2 before 2.2.28, 3.2 before 3.2.13, and 4.0 before 4.0.4. QuerySet.annotate(), aggregate(), and extra() methods are subject to SQL injection in column aliases via a crafted dictionary (with dictionary expansion) as the passed **kwargs.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdjango≥ 2.2&&< 2.2.282.2.28pip install --upgrade 'django==2.2.28'
🐍PyPIdjango≥ 3.2&&< 3.2.133.2.13pip install --upgrade 'django==3.2.13'
🐍PyPIdjango≥ 4.0&&< 4.0.44.0.4pip install --upgrade 'django==4.0.4'

Affected Products

2 products · 5 configurations
OS
debian linuxdebian
2 versions
9.011.0
Application
djangodjangoproject
≥ 4.0 && < 4.0.4
range
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update django to 2.2.28 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-28346 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

Red Hat OpenStack does ship the affected version of Django, however, vulnerability is not exposed in the product as it does not make use of vulnerable code. We may update Django in a future release of OpenStack.

ProductFixed inAdvisory
Red Hat Ansible Automation Platform 2.1 for RHEL 8automation-controller-0:4.1.2-2.el8apRHSA-2022:5702
Red Hat Automation Hub 4.2 for RHEL 7python3-django-0:2.2.28-1.el7pcRHSA-2022:5703
Red Hat OpenStack Platform 16.1python-django20-0:2.0.13-18.el8ostRHSA-2022:8872
Red Hat OpenStack Platform 16.2python-django20-0:2.0.13-17.el8ostRHSA-2022:5115
Red Hat Satellite 6.11 for RHEL 8python-django-0:3.2.13-1.el8pcRHSA-2022:5498
RHUI 4 for RHEL 8python-django-0:3.2.13-2.el8uiRHSA-2022:5602

Frequently Asked Questions

An issue was discovered in Django 2.2 before 2.2.28, 3.2 before 3.2.13, and 4.0 before 4.0.4. QuerySet.annotate(), aggregate(), and extra() methods are subject to SQL injection in column aliases via a crafted dictionary (with dictionary expansion) as the passed **kwargs.
O3 Security · Impact-Aware SCA

Is CVE-2022-28346 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-28346: django SQL Injection — Fixed in 2.2.28