NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

Laravel RCE vulnerability in "cookie" session driverGHSA-2ffv-r4r9-r8xr

GHSA-2ffv-r4r9-r8xr is a remote code execution vulnerability in illuminate/cookie. A fix is available for illuminate/cookie — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 29, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🐘illuminate/cookie🐘illuminate/cookie

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Application's using the "cookie" session driver were the primary applications affected by this vulnerability. Since we have not yet released a security release for the Laravel 5.5 version of the framework, we recommend that all applications running Laravel 5.5 and earlier do not use the "cookie" session driver in their production deployments.

Regarding the vulnerability, applications using the "cookie" session driver that were also exposing an encryption oracle via their application were vulnerable to remote code execution. An encryption oracle is a mechanism where arbitrary user input is encrypted and the encrypted string is later displayed or exposed to the user. This combination of scenarios lets the user generate valid Laravel signed encryption strings for any plain-text string, thus allowing them to craft Laravel session payloads when an application is using the "cookie" driver.

This fix prefixes cookie values with an HMAC hash of the cookie's name before encryption and then verifies a matching hash on decryption, making it impossible to craft a valid cookie payload even if an encryption oracle is exposed via the application.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistilluminate/cookie≥ 4.1.0&&< 6.18.316.18.31composer require illuminate/cookie:^6.18.31
🐘Packagistilluminate/cookie≥ 7.0.0&&< 7.22.47.22.4composer require illuminate/cookie:^7.22.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for illuminate/cookie, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update illuminate/cookie to 6.18.31 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2ffv-r4r9-r8xr is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Application's using the "cookie" session driver were the primary applications affected by this vulnerability. Since we have not yet released a security release for the Laravel 5.5 version of the framework, we recommend that all applications running Laravel 5.5 and earlier do not use the "cookie" session driver in their production deployments. Regarding the vulnerability, applications using the "cookie" session driver that were also exposing an encryption oracle via their application were vulnerable to remote code execution. An encryption oracle is a mechanism where arbitrary user input is enc
O3 Security · Impact-Aware SCA

Is GHSA-2ffv-r4r9-r8xr in your dependencies?

Find it across Packagist, including transitive dependencies.

Laravel RCE vulnerability in "cookie" session driver