NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

Laravel Cookie serialization vulnerabilityGHSA-2867-6rrm-38gr

GHSA-2867-6rrm-38gr is a security vulnerability in illuminate/cookie. A fix is available for illuminate/cookie — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 29, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected
🐘illuminate/cookie

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Laravel 5.6.30 is a security release of Laravel and is recommended as an immediate upgrade for all users. Laravel 5.6.30 also contains a breaking change to cookie encryption and serialization logic. Refer to laravel advisory for more details and read the notes carefully when upgrading your application.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistilluminate/cookie≥ 5.5.0&&< 5.6.305.6.30composer require illuminate/cookie:^5.6.30

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for illuminate/cookie, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update illuminate/cookie to 5.6.30 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2867-6rrm-38gr is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Laravel 5.6.30 is a security release of Laravel and is recommended as an immediate upgrade for all users. Laravel 5.6.30 also contains a breaking change to cookie encryption and serialization logic. Refer to [laravel advisory](https://laravel.com/docs/5.6/upgrade#upgrade-5.6.30) for more details and read the notes carefully when upgrading your application.
O3 Security · Impact-Aware SCA

Is GHSA-2867-6rrm-38gr in your dependencies?

Find it across Packagist, including transitive dependencies.

Laravel Cookie serialization vulnerability