NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

Keycloak's admin API allows low privilege users to use administrative functionsGHSA-2cww-fgmg-4jqc

HIGHFix: keycloak/keycloak@d9f0c84

GHSA-2cww-fgmg-4jqc is a high-severity (CVSS 8.1) Information Exposure vulnerability in org.keycloak:keycloak-services. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.keycloak:keycloak-services — see the affected versions and patch details below.

Also known asCVE-2024-3656
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-2cww-fgmg-4jqc.

EPSS Exploitation Probability

via FIRST.org ↗
3.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
0.00%33.3%66.7%100.0%89.7%3.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.keycloak:keycloak-services

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Users with low privileges (just plain users in the realm) are able to utilize administrative functionalities within Keycloak admin interface. This issue presents a significant security risk as it allows unauthorized users to perform actions reserved for administrators, potentially leading to data breaches or system compromise.

Acknowledgements: Special thanks to Maurizio Agazzini for reporting this issue and helping us improve our project.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.keycloak:keycloak-servicesall versions24.0.5org.keycloak:keycloak-services:24.0.5
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.keycloak:keycloak-services, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.keycloak:keycloak-services to 24.0.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2cww-fgmg-4jqc is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

How to detect GHSA-2cww-fgmg-4jqc

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id ghsa-2cww-fgmg-4jqc -u https://target
Template
Keycloak < 24.0.5 - Broken Access Control
Severity
high
Impact
Authenticated low-privilege users can access administrative functionalities, potentially leading to data breaches or system compromise.
Remediation
Update Keycloak to version 24.0.5 or later.

Template by ProjectDiscovery nuclei-templates (iamnoooob, rootxharsh, pdresearch), MIT licensed. View the full template. Scan only systems you are authorised to test.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

Red Hat has evaluated this vulnerability. This affects only Keycloak server and no Keycloak clients library ship the affected code.

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for GHSA-2cww-fgmg-4jqc (CC BY 4.0)

Frequently Asked Questions

Users with low privileges (just plain users in the realm) are able to utilize administrative functionalities within Keycloak admin interface. This issue presents a significant security risk as it allows unauthorized users to perform actions reserved for administrators, potentially leading to data breaches or system compromise. **Acknowledgements:** Special thanks to Maurizio Agazzini for reporting this issue and helping us improve our project.
O3 Security · Impact-Aware SCA

Is GHSA-2cww-fgmg-4jqc in your dependencies?

Find it across Maven, including transitive dependencies.

Keycloak's admin API allows low privilege users to use…