CVE-2024-3656 is a high-severity (CVSS 8.1) Information Exposure vulnerability in org.keycloak:keycloak-services. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.keycloak:keycloak-services — see the affected versions and patch details below.
Keycloak: unguarded admin rest api endpoints allows low privilege users to use administrative functionalities
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-3656.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.keycloak:keycloak-servicesReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Users with low privileges (just plain users in the realm) are able to utilize administrative functionalities within Keycloak admin interface. This issue presents a significant security risk as it allows unauthorized users to perform actions reserved for administrators, potentially leading to data breaches or system compromise.
Acknowledgements: Special thanks to Maurizio Agazzini for reporting this issue and helping us improve our project.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.keycloak:keycloak-services | all versions | 24.0.5org.keycloak:keycloak-services:24.0.5 |
Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.keycloak:keycloak-services, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.keycloak:keycloak-services to 24.0.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-3656 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
How to detect CVE-2024-3656
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2024-3656 -u https://target- Template
- Keycloak < 24.0.5 - Broken Access Control
- Severity
- high
- Impact
- Authenticated low-privilege users can access administrative functionalities, potentially leading to data breaches or system compromise.
- Remediation
- Update Keycloak to version 24.0.5 or later.
Template by ProjectDiscovery nuclei-templates (iamnoooob, rootxharsh, pdresearch), MIT licensed. View the full template. Scan only systems you are authorised to test.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat has evaluated this vulnerability. This affects only Keycloak server and no Keycloak clients library ship the affected code.
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2024-3656 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2024-3656 in your dependencies?
Find it across Maven, including transitive dependencies.