Elasticsearch vulnerable to Uncontrolled Resource ConsumptionGHSA-2cqf-6xv9-f22w
HIGHGHSA-2cqf-6xv9-f22w is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in org.elasticsearch:elasticsearch. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.elasticsearch:elasticsearch — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.elasticsearch:elasticsearch☕org.elasticsearch:elasticsearchReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
An issue has been identified with how Elasticsearch handled incoming requests on the HTTP layer. An unauthenticated user could force an Elasticsearch node to exit with an OutOfMemory error by sending a moderate number of malformed HTTP requests. The issue was identified by Elastic Engineering and we have no indication that the issue is known or that it is being exploited in the wild.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.elasticsearch:elasticsearch | all versions | 7.17.13org.elasticsearch:elasticsearch:7.17.13 |
| ☕Maven | org.elasticsearch:elasticsearch | ≥ 8.0.0&&< 8.9.0 | 8.9.0org.elasticsearch:elasticsearch:8.9.0 |
Affected Products
elastic cloud enterpriseelasticelasticsearchelasticResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.elasticsearch:elasticsearch, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.elasticsearch:elasticsearch to 7.17.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2cqf-6xv9-f22w is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is GHSA-2cqf-6xv9-f22w in your dependencies?
Find it across Maven, including transitive dependencies.