CVE-2024-23449 is a medium-severity (CVSS 4.3) CWE-248 vulnerability in org.elasticsearch:elasticsearch. A fix is available for org.elasticsearch:elasticsearch — see the affected versions and patch details below.
Elasticsearch Uncaught Exception
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-23449.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.elasticsearch:elasticsearchReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
An uncaught exception in Elasticsearch >= 8.4.0 and < 8.11.1 occurs when an encrypted PDF is passed to an attachment processor through the REST API. The Elasticsearch ingest node that attempts to parse the PDF file will crash. This does not happen with password-protected PDF files or with unencrypted PDF files.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.elasticsearch:elasticsearch | ≥ 8.4.0&&< 8.11.1 | 8.11.1org.elasticsearch:elasticsearch:8.11.1 |
Affected Products
elasticsearchelasticDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.elasticsearch:elasticsearch, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.elasticsearch:elasticsearch to 8.11.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-23449 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This CVE requires the attachment processor to be enabled. Users unable to upgrade can ensure that the attachment processor is disabled.Source: Red Hat security advisory for CVE-2024-23449 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2024-23449 in your dependencies?
Find it across Maven, including transitive dependencies.