NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🦀
🦀 crates.io
Not in CISA KEV
CRITICAL severity

Data races in rusqliteGHSA-28ph-f7gx-fqj8

CRITICALFix: rusqlite/rusqlite@3c6b57f

GHSA-28ph-f7gx-fqj8 is a critical-severity (CVSS 9.8) vulnerability in rusqlite. A fix is available for rusqlite — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs78th percentile — riskier than 78% of all scored CVEsHighest risk
0.00%0.75%1.49%2.24%0.4%1.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🦀rusqlite

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in the rusqlite crate before 0.23.0 for Rust. Memory safety can be violated via VTab / VTabCursor.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.iorusqliteall versions0.23.0cargo update -p rusqlite --precise 0.23.0

Affected Products

1 product · 1 configurations
Application
rusqliterusqlite_project
< 0.23.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rusqlite, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update rusqlite to 0.23.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-28ph-f7gx-fqj8 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

An issue was discovered in the rusqlite crate before 0.23.0 for Rust. Memory safety can be violated via create_module.
O3 Security · Impact-Aware SCA

Is GHSA-28ph-f7gx-fqj8 in your dependencies?

Find it across crates.io, including transitive dependencies.

Data races in rusqlite (Critical 9.8)