NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🦀
🦀 crates.io
Not in CISA KEV
HIGH severity

CVE-2021-45714 — rusqlite

HIGH

CVE-2021-45714 is a high-severity (CVSS 7.5) Use After Free vulnerability in rusqlite. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for rusqlite — see the affected versions and patch details below.

Use After Free in rusqlite

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
2 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.00%0.57%1.15%1.72%0.4%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🦀rusqlite🦀rusqlite

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in the rusqlite crate 0.25.x before 0.25.4 and 0.26.x before 0.26.2 for Rust. create_aggregate_function has a use-after-free.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.iorusqlite≥ 0.25.0&&< 0.25.40.25.4cargo update -p rusqlite --precise 0.25.4
🦀crates.iorusqlite≥ 0.26.0&&< 0.26.20.26.2cargo update -p rusqlite --precise 0.26.2

Affected Products

1 product · 2 configurations
Application
rusqliterusqlite_project
≥ 0.26.0 && < 0.26.2
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rusqlite, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update rusqlite to 0.25.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-45714 is resolved across your whole dependency graph.

  3. Workarounds

    Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.

Frequently Asked Questions

An issue was discovered in the rusqlite crate 0.25.x before 0.25.4 and 0.26.x before 0.26.2 for Rust. create_aggregate_function has a use-after-free.
O3 Security · Impact-Aware SCA

Is CVE-2021-45714 in your dependencies?

Find it across crates.io, including transitive dependencies.

CVE-2021-45714: rusqlite — Fixed in 0.25.4