Spring AI Vulnerable to OOM by attacker-controlled PDFGHSA-26gg-9gv2-v27j
MEDIUMGHSA-26gg-9gv2-v27j is a medium-severity (CVSS 6.5) Uncontrolled Resource Consumption vulnerability in org.springframework.ai:spring-ai-pdf-document-reader. A fix is available for org.springframework.ai:spring-ai-pdf-document-reader — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-26gg-9gv2-v27j.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.springframework.ai:spring-ai-pdf-document-reader☕org.springframework.ai:spring-ai-pdf-document-readerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Spring AI, a malicious PDF file can be crafted that triggers the allocation of unreasonable amounts of memory when handled by ForkPDFLayoutTextStripper.
Affected versions: Spring AI: 1.0.0 - 1.0.5 (fixed in 1.0.6), 1.1.0 - 1.1.4 (fixed in 1.1.5)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.springframework.ai:spring-ai-pdf-document-reader | ≥ 1.0.0&&< 1.0.6 | 1.0.6org.springframework.ai:spring-ai-pdf-document-reader:1.0.6 |
| ☕Maven | org.springframework.ai:spring-ai-pdf-document-reader | ≥ 1.1.0&&< 1.1.5 | 1.1.5org.springframework.ai:spring-ai-pdf-document-reader:1.1.5 |
Affected Products
spring aivmwareDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.ai:spring-ai-pdf-document-reader, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.springframework.ai:spring-ai-pdf-document-reader to 1.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-26gg-9gv2-v27j is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is GHSA-26gg-9gv2-v27j in your dependencies?
Find it across Maven, including transitive dependencies.